Erweiterte Tabellenansicht

Als PDF herunterladen

Übersicht

In nahezu allen Bereichen von Backstage werden Daten tabellarisch angezeigt. So können Sie alle Informationen ganz einfach handhaben und auswerten.

Screenshot der Tabellenansicht einer Rechnung mit einem benutzerdefinierten mehrzeiligen Layout.
Benutzerdefinierte Tabellenansicht der Rechnung

Hinweis

Die persönlichen Tabellenansichten werden automatisch je Benutzer gespeichert. Bei jeder neuen Anmeldung werden die zuletzt gemachten Einstellungen übernommen.

Mit Hilfe der leicht anzuwendenden Tabellenfunktionen haben Sie immer volle Übersicht und können Ihre Arbeitsumgebung optimieren:

  • Die Spalten lassen sich beliebig anordnen, unkompliziert hinzufügen oder entfernen.
  • Mit der Sortierung und Filterung kann nach beliebig vielen Kriterien selektiert werden.
  • Alle Ansichten sind individuell und beliebig an Ihre Bedürfnisse anzupassen.
  • Alle Daten sind exportierbar.

Steuerelemente und Funktionen der Tabellenansicht

Schnellsuche

Die Schnellsuche ermöglicht Ihnen das Auffinden bestimmter Daten anhand von Suchbegriffen. Die Suche kann dabei entweder über alle Felder oder lediglich in bestimmten Feldern ausgelöst werden.

  1. Klicken Sie auf Schnellsuche.
  2. Wählen Sie im Dropdown eine bestimmte Spalte aus oder suchen Sie in allen Feldern.
  3. Geben Sie Ihr Suchwort ein.
  4. Klicken Sie auf das Lupen-Symbol oder drücken Sie Enter.

Screenshot, der ein Schnellsuchfeld zum Filtern von Tabellendaten zeigt.
Schnellsuche: Suche in allen Feldern

Hinweis

Die Schnellsuche filtert Ihre Ergebnisse so lange, bis Sie sie löschen. Um wieder alle verfügbaren Daten zu sehen, öffnen Sie erneut die Schnellsuche, löschen Sie den Suchbegriff und bestätigen Sie per Klick auf das Lupen-Symbol oder mit Enter. Ob die Schnellsuche, Filter oder Sortierung aktiviert wurde, erkennen Sie an der blauen Schriftfarbe des jeweiligen Menüpunktes.

Tipp

Wildcard-Suche

Zur bequemen Eingrenzung des Suchbereichs können Sie mit Wildcards arbeiten. Wildcards sind Zeichen, die als Platzhalter dienen und einzelne oder mehrere Zeichen der Suchphrase ersetzen.

Backstage unterscheidet zwei Arten von Wildcards, die zu Beginn, in der Mitte oder am Ende der Suchphrase genutzt werden können:

“?” Fragezeichen: kann als Platzhalter für ein beliebiges Zeichen benutzt werden

“*” Sternchen: kann als Platzhalter für ein oder mehrere beliebige Zeichen benutzt werden

Filter anwenden

Die Filterfunktion erlaubt sehr differenzierte, mehrstufige Selektionen.
Klicken Sie auf Filter, um aus mehreren Bedingungen zu wählen und Ihre Suchergebnisse einzugrenzen:

  • Logik: Definiert die Art der Filterung:
    • Und - Zeilendefinitionen werden UND-verknüpft. Es müssen alle Filterkriterien erfüllt sein
    • Oder - Zeilendefinitionen werden ODER-verknüpft. Es muss ein Filterkriterium erfüllt sein
  • Feld: Definiert die Suche in allen Feldern oder beschränkt sie auf ein bestimmtes Feld.
  • Filter: Definiert die Art der Suche:
Wildcard Der Feldinhalt enthält den Wert der Eingabe.
Leer Die Datensätze werden nach leeren Feldern durchsucht.
Nicht leer Die Datensätze werden nach gefüllten Feldern durchsucht.
= Der Feldinhalt stimmt genau mit der Eingabe überein.
≠ Der Feldinhalt stimmt nicht mit der Eingabe überein.
< Der Zahl-Wert des Feldes ist kleiner als die Eingabe.
≤ Der Zahl-Wert des Feldes ist kleiner/gleich der Eingabe.
> Der Zahl-Wert des Feldes ist größer als die Eingabe.
≥ Der Zahl-Wert des Feldes ist größer/gleich der Eingabe.
  • Text/Wert: Geben Sie hier ihr Suchkriterium ein.
  • Klicken Sie auf das Plus-Symbol , um eine weitere Zeile für ein zusätzliches Kriterium einzufügen. Das Minus-Symbol löscht die Zeile mit ihren Vorgaben.
  • Klicken Sie Anwenden.

Screenshot, der die Filterkonfiguration mit mehreren Bedingungen zur Eingrenzung der Suchergebnisse in Tabellendaten zeigt.
Tabellenfilter: Suchkriterien konfigurieren

Hinweis

Bei der Verwendung der Filter lassen sich alle für die Tabellenansicht verfügbaren Felder einbeziehen, sogar wenn die betreffenden Spalten ausgeblendet sind.

Sortierung

Klicken Sie auf eine Spaltenüberschrift, um die Tabellendaten absteigend zu sortieren. Klicken Sie erneut, um zur aufsteigenden Sortierung zu wechseln. Ein Pfeil neben der Überschrift zeigt die aktuelle Sortierreihenfolge an:

Screenshot der Tabellenansicht mit sortierbaren Spalten; eine Spaltenüberschrift ist hervorgehoben.
Tabellensortierung: Spaltenüberschrift anklicken, um Daten zu sortieren

Oder

Klicken Sie auf Sortierung.

  • Feld: Legt die Spalte fest, nach der sortiert werden soll.
  • Richtung: Definiert die Art der Ausgabe der Sortierung:
Aufsteigend Sortiert die Feldinhalte der Spalte aufsteigend, mit dem kleinsten Wert oben.
Absteigend Sortiert die Feldinhalte der Spalte absteigend, mit dem größten Wert oben.

Optional: Fügen Sie weitere Kriterien hinzu, nach denen sortiert werden soll, wenn der Inhalt des ersten Feldes identisch ist.

Fügt eine weitere Zeile für eine weitere Sortierung ein.
Löscht die Zeile mit ihren Vorgaben.

Screenshot des Sortiermenüs, mit dem eine Tabelle nach mehreren Parametern sortiert werden kann.
Sortierungsmenü: Sortierungsparameter konfigurieren

Um mehrstufige Sortierungen aufzuheben, klicken Sie einfach auf einen Spaltenkopf in der Tabellenansicht. Mit dieser neuen Sortierung überschreiben Sie alle bisherigen Festlegungen unter Sortierung. Alternativ können Sie auch alle Sortierungskriterien unter Sortierung entfernen und über den Button Anwenden bestätigen.

Ansicht einrichten

Um eine Tabellenansicht individuell einzurichten gehen Sie wie folgt vor:

  1. Klicken Sie auf Ansicht > Einrichten.
  2. Geben Sie bei Name der Ansicht einen Namen ein.
  3. Wählen Sie das Zeilenlayout:
    • einzeilig: Für eine tabellarische Darstellung aller Datenbankfelder in einer Zeile.
      • Definieren Sie die Zeilenhöhe.
      • Verwenden Sie das Download-Menü, um die Auswahl der auszugebenden Datenbankfelder zu treffen.
      • Verschieben Sie die Datenbankfelder an die gewünschte Position – entweder per Drag & Drop oder mit den Pfeilsymbolen.
    • mehrzeilig: Für eine Darstellung aller Datenbankfelder in mehreren Zeilen.
      • Fügen Sie Spalten und Zeilen ein.
      • Verwenden Sie Pfeile, um Zellen zu verbinden.
  4. Klicken Sie Anwenden. Ihre gespeicherte Ansicht erscheint nun am Ende der Liste.

Screenshot des Dialogfelds „Tabellenansicht konfigurieren“. Die Navigationselemente zum Konfigurieren eines Tabellenlayouts mit einer einzigen Zeile sind hervorgehoben.
Tabellenansicht einrichten: Einzeilig

Screenshot des Dialogfelds „Tabellenansicht konfigurieren“. Die Navigationselemente zum Konfigurieren eines mehrzeiligen Tabellenlayouts sind hervorgehoben.
Tabellenansicht einrichten: Mehrzeilig

Verbindet die Zelle unterhalb des Pfeils mit der darunterliegenden abwärts.
Trennt die verbundenen Zellen aufwärts.
Verbindet die Zelle mit der rechts danebenliegenden.
Trennt die verbundenen Zellen nach links.

Hinweis

Die Zeilenhöhe definiert die Höhe der Zeilen. Die Mindesthöhe beträgt 24 Pixel. Falls Sie in Ihrer Ansicht Thumbnails anzeigen möchten, beachten Sie bitte, dass Sie einen ausreichend große Zeilenhöhe wählen. Für eine optimale Ansicht von Thumbnails empfehlen wir eine Höhe von 150 Pixeln. Wenn Sie einen zu kleinen Wert wählen, werden die Thumbnails entsprechend verkleinert, um in der Zeile dargestellt werden zu können.

Screenshot des Menüs „Ansichten“ für eine Tabelle. Die Navigationselemente zum Anzeigen, Konfigurieren, Zurücksetzen, Löschen und Speichern eines Tabellenlayouts sind hervorgehoben.
Ansichten: Die gespeicherte Ansicht am Ende der Liste

Hinweis

Jede Tabellenansicht verfügt über eine so genannte Systemansicht, eine vordefinierte Standardansicht. Diese Systemansicht ist für jeden Benutzer zugänglich und kann nicht gelöscht werden.

Ansicht verwalten

  • Um eine neue Ansicht zu erstellen, wählen Sie im Menü Ansichten > Ansicht speichern.
  • Um bestehende Ansichten zu verwalten, wählen Sie die bestehende Ansicht unter Ansichten. Klicken Sie auf. Ansichten > Einrichten. Modifizieren Sie die Ansicht nach Ihren Vorstellungen. Klicken Sie auf Speichern. Wählen Sie als Vorhandene Ansicht, die zu überspeichernde Ansicht.

Screenshot des Dialogfelds „Ansicht speichern“ zum Wiederverwenden von Tabellenlayouts und Filtern. Es werden Navigationselemente zum Erstellen und Speichern eines Tabellenlayouts sowie zum Aktivieren der Freigabe angezeigt.
Dialogfenster “Ansicht speichern”

  • Wenn Sie eine Tabellenansicht vorübergehend geändert haben, können Sie die ursprüngliche Ansicht schnell wiederherstellen, indem Sie Ansicht zurücksetzen auswählen.
  • Um eine bestehende Ansicht zu löschen, markieren Sie die gewünschte Datei aus der Liste und wählen Sie Bearbeiten > Löschen.

Export von Tabelleninhalten

Um Daten aus einer Tabellenansicht zu exportieren, gehen Sie wie folgt vor:

  1. Klicken Sie auf Export.
  2. Definieren Sie das Format Ihrer zu exportierenden Datei über folgende Kriterien:
    • Trennzeichen der Felder
    • Begrenzungszeichen der Felder
    • Zeichensatz
  3. Wählen Sie im Bereich Feldzuordnung für den Export die zu exportierenden Felder.
  4. Klicken Sie Export starten.
Fügt eine weitere Spalte oder Zeile in die Ansicht ein.
Löscht eine Spalte oder Zeile aus der Ansicht.

Screenshot eines Dialogfelds zum Exportieren von Tabellendaten. Es werden Navigationselemente zum Festlegen der Exporteinstellungen und zum Auswählen der für den Export verfügbaren Datenbankfelder angezeigt.
Kunden Übersicht: Tabellendaten exportieren

Tipp

Export-Vorlagen speichern

  • Klicken Sie auf den Menüpunkt Vorlagen > Als Vorlage speichern.
  • Die gespeicherten Vorlagen finden Sie unter Vorlagen.

Hinweis

Achten Sie beim Öffnen der Exportdatei darauf, dass Sie hier die identischen Formateinstellung (Trennzeichen, Begrenzungszeichen, Zeichensatz) wie beim Export nutzen.

Spalten konfigurieren

Verwenden Sie das Kontextmenü (Rechtsklick auf eine Spaltenüberschrift und Klick auf das ☰‑Symbol), um Spalten ein- oder auszublenden.

Wählen Sie die Felder aus, die angezeigt werden sollen, und deaktivieren Sie diejenigen, die ausgeblendet werden sollen. Die Reihenfolge der Spalten können Sie außerdem mit den Pfeilsymbolen ändern.

Screenshot des Kontextmenüs einer Tabelle. Das Kontextmenü‑Symbol ist hervorgehoben; das Tabellen‑Kontextmenü ist geöffnet und zeigt Optionen zum Verwalten von Feldern und zum Neuanordnen von Spalten.
Kontextmenü der Tabelle

Spaltenbreite anpassen

  • Ziehen Sie den rechten Rand mit der Maus auf das gewünschte Maß.

Tabellenhöhe anpassen

Um die Höhe des sichtbaren Tabellenbereichs anzupassen, ziehen Sie den unteren Rand.

Screenshot eines Dialogfelds zur Anpassung der Tabellenhöhe. Es wird das Navigationselement zum Festlegen der Höhe der Tabelle angezeigt.
Anpassung Höhe des sichtbaren Tabellenbereichs

Tipp

Stapelverarbeitung in Tabellenansichten

  1. Markieren Sie die gewünschten Datensätze.
    • Fortlaufende Markierung: Um eine fortlaufende Datenreihe zu markieren: SHIFT + Click.
    • Nicht-fortlaufende Markierung: Um eine nicht-fortlaufende Datenreihe zu markieren: STRG + Click (Windows), CMD + Click (Mac).
  2. Klicken Sie auf Bearbeiten > Stapelverarbeitung.
  3. Bearbeiten Sie alle markierten Datensätze auf einmal.

Tipp

Maximale Tabellenansicht

Sie benötigen mehr Platz für die Spalten? In Backstage können Sie das linke Navigationsmenü sowie den Header verbergen. Klicken Sie hierfür auf den Doppelpfeil. Mit erneutem Klicken wird das Menü wieder sichtbar.

Screenshot eines Backstage-Fensters mit dem Pfeilsymbol zum Ausblenden des linken Navigationsmenüs.
Navigationsmenü verbergen